Thai OpenCart ร้านค้าออนไลน์ ระบบ Opencart ภาษาไทย

OPENCART HOTLINE

บริการติดตั้งระบบ OpenCart พัฒนาระบบ UPGRADE Version

Facebook
LINE:elect.tu
MAIL:elect.tu@gmail.com
TEL:0890237235

[แจก]Thai Opencart 1.5.5.1 ภาษาไทย(อัปเกรดเป็น 1.5.6.4 ได้)

0 Members and 1 Guest are viewing this topic.

เนื่องจากไม่สามารถกู้ข้อมูลโฮสต์เก่าได้ ผมเลยขอโพสใหม่ ตัวนี้สามารถอัปไปเป็น 1564 ตัวล่าสุดได้ แต่จะมีภาษาบางตัวที่ไม่ได้แปลเพิ่มเช่นระบบ Profiles ของสินค้า

Quote
=============== Update 20 มิถุนายน 2556 ======

1.แก้ไขส่งอีเมล์หลังร้านไม่ได้
2.แก้ไข ckeditor ให้แสดงทูลบาร์ทั้งหมด

=============================================

1.อัปโหลดไฟล์ที่อยู่ในโฟลเดอร์ upload ขึ้นไปยังเซเวอร์ของท่าน

2.ตรวจสอบ premission ไฟล์และโฟลเดอร์ดังต่อไปนี้ ให้เป็น 777(CHMOD 777)

   -config.php
   -admin/config.php
   -download/
   -image/
   -image/cache/
   -image/data/
   -image/payment/
   -system/cache/
   -system/logs/
   -system/logs/error.txt
   -vqmod/
   -vqmod/vqcache/
3.ทำการติดตั้งตามปกติ โดยการเรียก url เว็บของท่าน เช่น http://www.123.com/ หรือ http://upload.123.com/ หรือ http://www.123.com/upload/ ตามแต่ท่านได้อัปโหลดขึ้น

4.สำหรับผู้ที่ใช้งานโฮสต์จำลอง เช่น AppServ และไม่ได้ติดตั้ง mCrypt ให้ทำการติดตั้ง mCrypt ให้เรียบร้อยก่อน และถ้าหากติดตั้งไม่ได้ ให้ท่านเปลี่ยนชื่อไฟล์ install/controller/step_2.php
เป็นอย่างอื่นก่อน จากนั้นเปลี่ยนชื่อ install/controller/step_2.php-No-mCrypt ให้เป็น install/controller/step_2.php และให้ทำการติดตั้งตามปกติ เมื่อทำการติดตั้งเสร็จเรียบร้อยแล้ว
ให้เข้าไปยัง system/library/encryption.php เปลี่ยนชื่อเป็นอะไรก็ได้ แล้วให้เปลี่ยนชื่อ encryption1531.php ให้เป็น encryption.php ท่านก็จะสามารถใช้งาน opencart 1.5.5.1 ได้ตามปกติ

5.ส่วนท่านที่ใช้งานบนโฮสต์จริงๆ ไม่ต้องทำตามขั้นตอนข้อ 4. เพราะว่าทุกโฮสต์จะมี mCrypt มาอยู่แล้วครับ

6.หลังจากติดตั้งเสร็จ อย่าลืมลบหรือเปลี่ยนชื่อโฟลเดอร์ install เพื่อป้องการการโดนแฮก และให้ chmod 644 ไฟล์ config.php และ admin/config.php กลับคืนด้วย เพื่อป้องกันการโดนแฮกด้วยเช่นกัน

มีอะไรอัปเดท สำหรับ Thai OpenCart 1.5.5.1?

สำหรับเวอร์ชั่นนี้ผม (Pickawan http://www.opencart2u.com/) รับหน้าที่แก้ไขและปรับปรุง รวมไปถึงเพิ่มเติมส่วนที่สำคัญลงไปในระบบ ต่างจากเวอร์ชั่นปกติที่โหลดมาจาก opencart.com แน่นอน

ส่วนที่เพิ่มเติมสำหรับเวอร์ชั่นนี้ (1.5.5.1)

1.เพิ่ม vqmod ลงไปในระบบ ทำให้มือใหม่ไม่ต้องติดตั้ง vqmod เพิ่มทีหลัง
2.เพิ่มโมดูลที่ผมแจกฟรีในเว็บ opencart2u.com ลงไปให้ด้วย ได้แก่
-bot visit
-visitors
-สถิติร้านค้า
-ไปรษณีย์ไทย
-แสดงสินค้าล่าสุดตามหมวดหมู่
-โมดูลแจ้งการโอนเงิน
-Thai Bank transfers 6 ธนาคาร
-เพิ่ม GEO Zone ระบบการจัดส่งสินค้า EMS และลงทะเบียน วึ่งสามารถใช้งานวิธีการจัดส่งสินค้าตามน้ำหนักได้ทันที
-ปรับปรุงโมดูล ข้อความต้อนรับ ให้กลายเป็น HTML Code ซึ่งทำให้โมดูลนี้ใช้งานแทนโมดูล FreeBox ได้ทันที

สุดท้าย

www.opencart2004.com
ให้ท่านใช้งานได้ระบบ Thai OpenCart ฟรี โดยมีข้อแม้นิดเดียวขอ TAG ไปยังเว็บผู้พัฒนา
โดยเราจะไม่คิดค่าใช้จ่ายใดๆ และให้คำปรึกษาในการใช้งาน

ดาวน์โหลดได้ที่

https://code.google.com/p/thaiopencart/downloads/detail?name=ThaiOpenCart1551-fix-email-and-ckeditor.zip&can=2&q=label%3Athai#makechanges

PASS:15512004 หรือ 20041551 ลองดูน่ะครับ
ADVERTISEMENT
« Last Edit: March 03, 2015, 09:18:04 AM by pickawan »
ดาวน์โหลด Template OpenCart สวยๆ คลิกเลย >>http://goo.gl/QtHq4G

ขอบคุณครับ

วีธีการอัปเกรดเป็น 1.5.6.4 ทำอย่างไรครับ ผมทำแล้วไม่เป็นภาษาไทย
ขอรายละเอียดหน่อยครับ ขอบคุณมากครับ

วีธีการอัปเกรดเป็น 1.5.6.4 ทำอย่างไรครับ ผมทำแล้วไม่เป็นภาษาไทย
ขอรายละเอียดหน่อยครับ ขอบคุณมากครับ
พอลงตัว 1551 fix เสร็จ แตกไฟล์ 1564 เอาไปทับของ 1551 เลย ยกเว้น config.php และ admin/config.php
จากนั้นเข้าเว็บ เรียก /install ระบบจะขึ้นหน้าจอให้อัปเกรด กดอัปเกรด เป็นอันเสร็จครับ
ดาวน์โหลด Template OpenCart สวยๆ คลิกเลย >>http://goo.gl/QtHq4G

ขอบคุณมากครับ

aftertimez

  • *
  • 1
  • Let's Try OpenCart
    • View Profile
    • Let's Try OpenCart
ขอโทษครับ ไม่ทรายว่า Password สำหรับแตกไฟล์คืออะไรครับ
ขอบคุณครับ

ขอโทษครับ ไม่ทรายว่า Password สำหรับแตกไฟล์คืออะไรครับ
ขอบคุณครับ

ไม่ 15512004 ก้อ 20041551 ครับ ผมจำไม่ได้แล้ว แต่ไม่เกินนี้ครับ
ดาวน์โหลด Template OpenCart สวยๆ คลิกเลย >>http://goo.gl/QtHq4G

โหลด Version 1.5.6.4 ใน web official มาค่ะ แล้วพอ Patch 1.5.5.1 มาลงมาวิธีที่บอกมาข้างต้นค่ะ

ตอนขั้นตอนที่สาม create table พอ Submit แล้วขึ้น error ดังนี้ค่ะ

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /Applications/MAMP/htdocs/opencart_test/system/database/mysql.php on line 6

Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/opencart_test/system/database/mysql.php:6) in /Applications/MAMP/htdocs/opencart_test/system/engine/controller.php on line 28

Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/opencart_test/system/database/mysql.php:6) in /Applications/MAMP/htdocs/opencart_test/system/engine/controller.php on line 29

ใช้ MAMP เป็น Server นะคะ php 5.5.10 แต่ถ้าลงโดยใช้ File จาก Web โดยตรงลงได้เรียบร้อยไม่ติดปัญหาอะไรนะคะ

เนื่องจากว่า php 5.5 ขึ้นไป ฟังก์ชั่น mysql_connect() ถูกเอาออกครับ ทำให้ใช้งานไม่ได้ มันเลยขึ้น

Deprecated: mysql_connect(): The mysql extension is deprecated

วิธีแก้ปัญหาคือ Downgrade php ไปใช้ 5.4 แทน กับอีกวิธีคือต้องไปแก้ไข class ของ db แทนครับ(ถ้าจะใช้ 1551 น่ะ)
ดาวน์โหลด Template OpenCart สวยๆ คลิกเลย >>http://goo.gl/QtHq4G

ขอบคุงคร๊าฟฟฟฟฟ  ;D

เนื่องจากไม่สามารถกู้ข้อมูลโฮสต์เก่าได้ ผมเลยขอโพสใหม่ ตัวนี้สามารถอัปไปเป็น 1564 ตัวล่าสุดได้ แต่จะมีภาษาบางตัวที่ไม่ได้แปลเพิ่มเช่นระบบ Profiles ของสินค้า

Quote
=============== Update 20 มิถุนายน 2556 ======

1.แก้ไขส่งอีเมล์หลังร้านไม่ได้
2.แก้ไข ckeditor ให้แสดงทูลบาร์ทั้งหมด

=============================================

1.อัปโหลดไฟล์ที่อยู่ในโฟลเดอร์ upload ขึ้นไปยังเซเวอร์ของท่าน

2.ตรวจสอบ premission ไฟล์และโฟลเดอร์ดังต่อไปนี้ ให้เป็น 777(CHMOD 777)

   -config.php
   -admin/config.php
   -download/
   -image/
   -image/cache/
   -image/data/
   -image/payment/
   -system/cache/
   -system/logs/
   -system/logs/error.txt
   -vqmod/
   -vqmod/vqcache/
3.ทำการติดตั้งตามปกติ โดยการเรียก url เว็บของท่าน เช่น http://www.123.com/ หรือ http://upload.123.com/ หรือ http://www.123.com/upload/ ตามแต่ท่านได้อัปโหลดขึ้น

4.สำหรับผู้ที่ใช้งานโฮสต์จำลอง เช่น AppServ และไม่ได้ติดตั้ง mCrypt ให้ทำการติดตั้ง mCrypt ให้เรียบร้อยก่อน และถ้าหากติดตั้งไม่ได้ ให้ท่านเปลี่ยนชื่อไฟล์ install/controller/step_2.php
เป็นอย่างอื่นก่อน จากนั้นเปลี่ยนชื่อ install/controller/step_2.php-No-mCrypt ให้เป็น install/controller/step_2.php และให้ทำการติดตั้งตามปกติ เมื่อทำการติดตั้งเสร็จเรียบร้อยแล้ว
ให้เข้าไปยัง system/library/encryption.php เปลี่ยนชื่อเป็นอะไรก็ได้ แล้วให้เปลี่ยนชื่อ encryption1531.php ให้เป็น encryption.php ท่านก็จะสามารถใช้งาน opencart 1.5.5.1 ได้ตามปกติ

5.ส่วนท่านที่ใช้งานบนโฮสต์จริงๆ ไม่ต้องทำตามขั้นตอนข้อ 4. เพราะว่าทุกโฮสต์จะมี mCrypt มาอยู่แล้วครับ

6.หลังจากติดตั้งเสร็จ อย่าลืมลบหรือเปลี่ยนชื่อโฟลเดอร์ install เพื่อป้องการการโดนแฮก และให้ chmod 644 ไฟล์ config.php และ admin/config.php กลับคืนด้วย เพื่อป้องกันการโดนแฮกด้วยเช่นกัน

มีอะไรอัปเดท สำหรับ Thai OpenCart 1.5.5.1?

สำหรับเวอร์ชั่นนี้ผม (Pickawan http://www.opencart2u.com/) รับหน้าที่แก้ไขและปรับปรุง รวมไปถึงเพิ่มเติมส่วนที่สำคัญลงไปในระบบ ต่างจากเวอร์ชั่นปกติที่โหลดมาจาก opencart.com แน่นอน

ส่วนที่เพิ่มเติมสำหรับเวอร์ชั่นนี้ (1.5.5.1)

1.เพิ่ม vqmod ลงไปในระบบ ทำให้มือใหม่ไม่ต้องติดตั้ง vqmod เพิ่มทีหลัง
2.เพิ่มโมดูลที่ผมแจกฟรีในเว็บ opencart2u.com ลงไปให้ด้วย ได้แก่
-bot visit
-visitors
-สถิติร้านค้า
-ไปรษณีย์ไทย
-แสดงสินค้าล่าสุดตามหมวดหมู่
-โมดูลแจ้งการโอนเงิน
-Thai Bank transfers 6 ธนาคาร
-เพิ่ม GEO Zone ระบบการจัดส่งสินค้า EMS และลงทะเบียน วึ่งสามารถใช้งานวิธีการจัดส่งสินค้าตามน้ำหนักได้ทันที
-ปรับปรุงโมดูล ข้อความต้อนรับ ให้กลายเป็น HTML Code ซึ่งทำให้โมดูลนี้ใช้งานแทนโมดูล FreeBox ได้ทันที

สุดท้าย

www.opencart2004.com
ให้ท่านใช้งานได้ระบบ Thai OpenCart ฟรี โดยมีข้อแม้นิดเดียวขอ TAG ไปยังเว็บผู้พัฒนา
โดยเราจะไม่คิดค่าใช้จ่ายใดๆ และให้คำปรึกษาในการใช้งาน

ดาวน์โหลดได้ที่

https://code.google.com/p/thaiopencart/downloads/detail?name=ThaiOpenCart1551-fix-email-and-ckeditor.zip&can=2&q=label%3Athai#makechanges

ต้อง install 1.5.5.1 ก่อนไหมครับ หรือว่า up host แล้วเอา 1.5.6.4 ไปทับเลยครับ

ต้อง install 1.5.5.1 ก่อนไหมครับ หรือว่า up host แล้วเอา 1.5.6.4 ไปทับเลยครับ

งงกับคำถามครับ ตัวนี้มันตัวเต็มของ 1551 ถ้าจะใช้ก็ต้องติดตั้ง 1551 ก่อนครับ แล้วถ้าจะอัปเกรดไปใช้ 1564 ก็โหลด 1564 มาทับแล้วเรียก install ใหม่ครับ
ดาวน์โหลด Template OpenCart สวยๆ คลิกเลย >>http://goo.gl/QtHq4G

ขอบคุณครับ